Résolution des erreurs de permission de base de données.
Vous rencontrez des problèmes liés aux autorisations de base de données avec Duplicator Pro ? Ce guide fournit des solutions pratiques pour dépanner et résoudre efficacement les différents problèmes liés aux autorisations de base de données.
Pour commencer, assurez-vous d'utiliser la dernière version de Duplicator Pro. Veuillez consulter le journal des modifications et la configuration requise.
Messages d'erreur courants
Si vous utilisez Duplicator à n'importe quelle étape et que vous recevez un message concernant un problème d'accès à la base de données, envisagez ces solutions :
Si vous rencontrez des problèmes de connexion à la base de données pendant le processus d'installation, veuillez consulter la FAQ ci-dessous et accéder à la section intitulée « Accès refusé » pour les étapes de dépannage :
Comment résoudre divers problèmes de base de données ?
Messages de commande refusée
Si vous rencontrez des messages « commande refusée », envisagez les options ci-dessous.
Privilèges minimum requis : Plutôt que d'accorder TOUS LES PRIVILÈGES, Duplicator n'a besoin que des éléments suivants pour terminer une installation : SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, ALTER, INDEX et LOCK TABLES. Si votre hébergeur ou votre politique de sécurité préfère accorder l'ensemble minimum, fournissez cette liste à votre fournisseur d'hébergement ou à votre DBA.
Si vous préférez simplifier les choses, dans cPanel, cochez la case « Tous les privilèges » pour l'utilisateur de la base de données qui rencontre des problèmes d'accès. Voici quelques exemples :
- Comment accorder tous les privilèges à un utilisateur MySQL avec cPanel
- Comment créer ou supprimer une base de données ou un utilisateur MySQL
Pour diverses options de ligne de commande, voir Vue d'ensemble générale de GRANT
Si vous rencontrez des problèmes de base de données lors de la création de sauvegarde plutôt que de l'installation, voir Résolution des problèmes de build liés à la base de données. Pour les erreurs d'écriture spécifiquement lors de l'installation, voir Comment corriger les problèmes d'écriture de base de données.