Gestion des échecs de build dus aux limites PHP 32 bits
Si la création échoue avec une discordance du nombre de fichiers/dossiers ou si la taille du résultat est une valeur de taille négative (c.-à-d. TAILLE : -1724710633B), il est possible que vous utilisiez une version 32 bits de PHP. Ces types d'erreurs indiquent que le serveur exécute PHP 32 bits et que le site dépasse 2,1 Go. Malheureusement, PHP 32 bits ne peut traiter/créer que des fichiers d'archive de moins de 2,1 Go.
Messages d'erreur courants
- Discordance de hachage sur une entrée de fichier DupArchive
- Le nombre de fichiers attendus (xxxxx) n'est pas égal au nombre écrit
- Le nombre de répertoires attendus (xxxxx) n'est pas égal au nombre écrit
Validation
Pour valider si votre système exécute le PHP 32 bits, allez dans Duplicator Pro » Outils » Infos serveur » PHP et regardez la valeur de la configuration « Architecture ».
Si vous ne pouvez pas accéder à la page Outils, vous pouvez également vérifier via un fichier phpinfo : créez un fichier contenant <?php phpinfo(); ?>, téléchargez-le sur votre site et ouvrez-le dans un navigateur. Recherchez la valeur « Architecture » ou « PHP Extension Build », une entrée contenant « x86 » indique généralement 32 bits, tandis que « x64 » indique 64 bits. Supprimez le fichier après vérification, car la sortie de phpinfo ne doit pas être laissée publiquement accessible. Consultez cet article pour plus d'informations.

Solutions
Si vous utilisez PHP 32 bits et que le site est volumineux (plus de 2,1 Go), vous avez trois options :
Option 1
Demandez à votre hébergeur de mettre à niveau PHP vers une version PHP 64 bits. Presque tous les hébergeurs prennent en charge PHP 64 bits de nos jours.
Option 2
Filtrez les fichiers/dossiers inutiles à l'aide des filtres dans Sauvegardes » Étape 1 (Configuration) pour que la taille soit inférieure à 2,1 Go.
Si votre build est également lent en plus d'atteindre cette limite de taille, consultez Comment accélérer le processus de build de sauvegarde lent.
Option 3
Effectuez une migration en 2 étapes qui minimise la taille de la sauvegarde en utilisant la technique Installation en deux parties.