Get the Best WordPress Backup
& Migration Plugin Today
Get Duplicator Now

Duplicator Documentation

Documentation, Reference Materials, and Tutorials for Duplicator

System Requirements for Duplicator

Are you wondering if your site is compatible with Duplicator? If you arrived here from your WordPress dashboard, it means you’re using an outdated PHP version, which is either insecure or no longer supported. You might also be running an outdated WordPress version incompatible with Duplicator.

This guide outlines the required PHP and WordPress versions for our plugin.

What is PHP?

PHP is widely used as the programming language, for WordPress and Duplicator.

Upgrading to versions of PHP offers improved speed and security benefits. We notify users who are using PHP versions because it puts their website at risk without security updates.

The easiest solution is to get in touch with your web hosting provider and ask them to update the PHP version for your hosting account. Usually this process is straightforward. Your web host should be proactive, in assisting you with it.

If your hosting company refuses to upgrade your PHP version or provide guidance through your hosting control panel it suggests that they do not prioritize the security of your website. In cases we recommend considering switching to one of the WordPress hosting providers suggested in WPBeginners article.

PHP Version Requirements for Duplicator

In case your web hosting company asks, below are the PHP version requirements for Duplicator.

Duplicator Lite and Pro: PHP 5.6.20 and above.

Note: WordPress itself requires PHP 7.4+ for the latest updates. Duplicator recommends using PHP 7.0+ or higher when possible.

WordPress Version Requirements

Duplicator (Lite and Pro) requires at least WordPress version 4.9 or higher to function properly.

To ensure your plugins are always compatible with your site, it’s essential to use the latest versions of both WordPress and Duplicator.

Frequently Asked Questions

These are some of the most common questions we receive about our plugin

Which version of PHP should I update to?
You should update your PHP version to 7.4 or higher. Ideally, you should upgrade to the latest version your web host offers. Most sites can upgrade to PHP 7+ without issues.
How do I update my site’s PHP version?
Web hosts have the ability to update your PHP version. In most cases, you can upgrade within your web hosting control panel or by submitting a support ticket to your host.
How to get Duplicator to run with older versions of PHP?
Duplicator Pro: For support of PHP 5.2.17 thru 5.6.19 please submit a help ticket for a compatible version.

Duplicator Lite: See Previous Versions Section (bottom of page) on the website.
Which is the recommended Database?
MySQL 5.0+ and MariaDB 10.0+
Web Servers: Apache, LiteSpeed, Nginx, Lighttpd, IIS, WebServerX.
Optional Dependencies
These features of PHP are not required, however they can improve the usability of the plugin. Some hosts may have these items already enabled.

PHP ZipArchive
shell_exec with zip support
Was this article helpful?

Related Articles