Question AServer Requirements
Is my server/host compatible with the Duplicator?
Duplicator Lite & Pro work on 99% of all servers, however if your host does not support the plugin we can issue a refund.
- WordPress 4.0+
- Duplicator Lite: PHP 5.3.8+
Duplicator Pro: PHP 5.6.20+
- MySQL 5.0+, MariaDB 10.0+
- Web Servers: Apache, LiteSpeed, Nginx, Lighttpd, IIS, WebServerX
Note: 99% of all hosting companies will meet these basic requirements. For a full break-down of setup recommendations see theDuplicator Pro recommended hosts page.
The Lite version of Duplicator does not officially support managed hosts at this time. There is currently a unification project underway to merge both the Pro and Free code linesso that the Free product can also take advantage of these features. The unification project is slated for late 2023, until that time only support for managed hostingwill reside in the Pro product version 4.0.0 and above.
Duplicator Pro does currently supports the managed hosts below.Managed WordPress Hosting is a tailor-made and optimized type of web hosting that is specifically designed to support WordPresssites on a companies servers.These types of configuration do not typically follow the standard host models and require additional logic to support.
- GoDaddy Managed WordPress
- WordPress.com Hosting
- Liquid Web Managed WordPress
- Flywheel Managed WordPress
- Pantheon Managed WordPress
- WP Engine Managed Hosting
- Your host not listed? Let us know!
Question BPHP Requirements
What version of PHP Does Duplicator Support?
The table below shows Duplicator PHP support levels. Duplicator Lite currently require PHP 5.3.8+ and Duplicator Pro requires PHP 5.6.20+.Duplicator recommends using PHP 7.0+ or higher when possible.
|PHP Version||Pro Version||Lite Version|
|before 5.2.16||not supported||not supported|
|5.2.17 thru 7.4.15||1.0.0 thru 22.214.171.124||1.0.0 thru 126.96.36.199|
|5.3.8 thru 8.0.0||4.0.0 thru 4.5.2||1.4.0+|
|5.6.20 thru 8.1.0+||4.5.3+||1.4.5+|
Older version of Duplicator can run on PHP 5.2.17 to 5.6.19. If using an older PHP version we recommend to upgrade for these reasons:
- PHP is phasing out support for older versions
- Many versions of PHP have hit end of life
- Newer version are more widely supported and more secure
- Many plugin and theme authors are no longer supporting older PHP versions
How to get Duplicator to run with older versions of PHP?
- Duplicator Pro: For support of PHP 5.2.17 thru 5.6.19 please submit a help ticket for a compatible version.
- Duplicator Lite: See Previous Versions Section (bottom of page)on the WordPress.org website.
These features of PHP are not required, however they can improve the useability of the plugin. Some hosts may have these items already enabled.
- PHP ZipArchive
- shell_exec with zip support